2.4L Thermostat Failing - Page 3 - 2014+ Jeep Cherokee Forums
User Tag List

 10Likes
Reply
 
LinkBack Thread Tools
post #21 of 42 (permalink) Old 01-21-2016, 02:05 PM Thread Starter
Member
 
Join Date: Oct 2015
Location: Omaha, Nebraska
Posts: 54
Update on Thermostats

Ive heard that Chrysler STAR is seeing this mostly only on fleet and rental vehicles. Dont know why this would be any different but they are also seeing them between 20-30K miles. A Chrysler rep stated to try disconnecting the battery and then reconnecting to see if this helps... LOL
Nielcoop is offline  
Sponsored Links
Advertisement
 
post #22 of 42 (permalink) Old 02-18-2016, 08:05 PM
Member
 
Join Date: Feb 2016
Posts: 1
Thermostat Updates

Mine started back in December after only 14,000 miles. Check engine light came on, wouldn't show temp above 185, blows cold air even on full heat and then had a "Service Electronic Throttle Control" and "Engine Temperature Hot" message and no temperature reading. Shut the car off and then back on to have the temp read 112. Took to the dealership and they cleared the fault and was told "It was an inactive fault." The light came back on before I got home. Called them back and was told the thermostats were on national back order and wouldn't know when they would get it. The next morning it was 7 degrees and I drove to work with no heat and numb feet so I decided their answer wasn't good enough and filed a complaint with Chrysler Customer Service. Was told they were still on back order but they found one and had it next day aired to my dealership, was given a tracking number and was addressed to me. So I call to get it back in but next available date was 2 weeks later. I dropped it off Tuesday morning then around 1 pm was told that the parts department sold my thermostat to Enterprise. I was not a happy camper so after a long talk with the dealership's General Manager and another complaint with Chrysler and now I'm cruising around in an Enterprise (Oh the irony) Challenger thanks to Chrysler with wonderful heat until they fix mine.
Hank4WVU is offline  
post #23 of 42 (permalink) Old 02-18-2016, 08:50 PM
Hardcore Member
 
Desoto's Avatar
 
Join Date: Apr 2014
Posts: 599
I really don't know what's going on with these T-Stats. I have a couple that I ordered due to previous discussions here on the last backorder, but have had no need to use them. It might be an extreme cold thing. Have any members in mild climate's had any issues?
Desoto is offline  
 
post #24 of 42 (permalink) Old 11-13-2016, 08:58 AM
Enthusiast Member
 
Tmugz88's Avatar
 
Join Date: Jun 2016
Location: Northern Wisconsin
Posts: 253
Garage
Sorry to bring this post back to life, but I've been having a P0128 (Thermostat Rationality) code that keeps coming back so it's going in on Tuesday. Is this part of the issues many other members are having with their I4? Some times at startup as I've stated in previous posts, it shutters really bad and the RPM's seem to jump from the low end to as high as 1200rpm's . After about 30sec it'll level off but if I even attempt to put it in gear it almost feels as if it's going to stall out .


Tmugz

2017 Jeep Cherokee Trailhawk 3.2L V6 Rhino
Cold Weather Group/Tow Group/Bi-Xenon

Replaced

2015 Jeep Cherokee Latitude (Problem Child)
Tmugz88 is offline  
post #25 of 42 (permalink) Old 11-14-2016, 12:36 PM
Premium Member
 
Join Date: Apr 2016
Posts: 382
Quote:
Originally Posted by Tmugz88 View Post
Sorry to bring this post back to life, but I've been having a P0128 (Thermostat Rationality) code that keeps coming back so it's going in on Tuesday. Is this part of the issues many other members are having with their I4? Some times at startup as I've stated in previous posts, it shutters really bad and the RPM's seem to jump from the low end to as high as 1200rpm's . After about 30sec it'll level off but if I even attempt to put it in gear it almost feels as if it's going to stall out .


Tmugz
Hi Tmugz,

If you have any questions or concerns after your dealership appointment please let me know!

Andrea
Jeep Social Care Specialist
JeepCares is online now  
post #26 of 42 (permalink) Old 11-14-2016, 01:12 PM
Enthusiast Member
 
Tmugz88's Avatar
 
Join Date: Jun 2016
Location: Northern Wisconsin
Posts: 253
Garage
Quote:
Originally Posted by JeepCares View Post
Hi Tmugz,

If you have any questions or concerns after your dealership appointment please let me know!

Andrea
Jeep Social Care Specialist
I appreciate the concern, I will be bringing it in this afternoon to have them hopefully diagnose the issue. They told me the thermostat job is about a 4hr job and they aren't sure if they will have a loaner to lend out to me so I'll have to figure that aspect out as I work full time .

Tmugz

2017 Jeep Cherokee Trailhawk 3.2L V6 Rhino
Cold Weather Group/Tow Group/Bi-Xenon

Replaced

2015 Jeep Cherokee Latitude (Problem Child)
Tmugz88 is offline  
post #27 of 42 (permalink) Old 11-14-2016, 09:25 PM
Hardcore Member
 
jamie1's Avatar
 
Join Date: Dec 2013
Posts: 870
Quote:
Originally Posted by Tmugz88 View Post
I appreciate the concern, I will be bringing it in this afternoon to have them hopefully diagnose the issue. They told me the thermostat job is about a 4hr job and they aren't sure if they will have a loaner to lend out to me so I'll have to figure that aspect out as I work full time .

Tmugz
Not quite 4 hours, but they are a biatch.
Tmugz88 likes this.
jamie1 is offline  
post #28 of 42 (permalink) Old 11-14-2016, 09:58 PM
Enthusiast Member
 
Tmugz88's Avatar
 
Join Date: Jun 2016
Location: Northern Wisconsin
Posts: 253
Garage
Well the confirmed it, the thermostat is indeed the problem , it's ordered and awaiting the call that it's come in.

Sent from my SM-G930V using Tapatalk

2017 Jeep Cherokee Trailhawk 3.2L V6 Rhino
Cold Weather Group/Tow Group/Bi-Xenon

Replaced

2015 Jeep Cherokee Latitude (Problem Child)
Tmugz88 is offline  
post #29 of 42 (permalink) Old 11-15-2016, 09:39 AM
Premium Member
 
Join Date: Apr 2016
Posts: 382
Quote:
Originally Posted by Tmugz88 View Post
I appreciate the concern, I will be bringing it in this afternoon to have them hopefully diagnose the issue. They told me the thermostat job is about a 4hr job and they aren't sure if they will have a loaner to lend out to me so I'll have to figure that aspect out as I work full time .

Tmugz
Hi Tmugz,

If they don't have a loaner available I would recommend asking if they have Courtesy Shuttle. Let me know how your appointment goes!

Andrea
Jeep Social Care Specialist
JeepCares is online now  
post #30 of 42 (permalink) Old 01-25-2017, 07:33 AM
Member
 
Join Date: Jan 2017
Posts: 1
My thermostat when bad in December so I took it to the dealer, they said it was bad and they would order one and contact me. Well after a week I called to see if it came in and they told me they ordered the wrong one, but had the right one on order so they went ahead and made an appointment. Fast forward to the appointment they said that they ordered the wrong one and they were sorry it was a mix up that they would order one again. That has been over 2 weeks ago and they still do not have the part in.
Slov02 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the 2014+ Jeep Cherokee Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



  Similar Threads
Thread Thread Starter Forum Replies Last Post
Thermostat/Coolant Temp. Steveinmedford Owners' Garage 14 06-01-2015 11:16 PM
Engine failing to start Len1304 Engine and Technical Discussion 14 10-27-2014 04:10 PM
HID kit installed with failing results Dundas Electronics, Audio, and Lighting 14 02-28-2014 11:16 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On