Battery voltage on EVIC at rest vs whilst Driving - Page 2 - 2014+ Jeep Cherokee Forums
User Tag List

 5Likes
Reply
 
LinkBack Thread Tools
post #11 of 55 (permalink) Old 01-11-2017, 07:29 PM
Moderator
 
Join Date: Dec 2014
Location: NOVA (Ashburn), VA
Posts: 2,138
Quote:
Originally Posted by DanWA View Post
Are those numbers testing the battery directly using a tool? Or just going off the Battery Voltage EVIC #. My concern was 12v was too low with engine off, but I am going off of the EVIC # alone
I have an external device provide telemetry, independent of the vehicle electronics. Keep in mind that with the ignition "on" (engine not running) there is a pretty significant load with the electronics on.

'15 Deep Cherry Red TH w/Brown Interior. 3.2L V-6
Safety-Tec, Cold Weather, Technology, Comfort, Tow, Leather.
Gobi Stealth roof rack with ladder.
My testing platform for electronics/telemetry experimenting.
Rojhan is offline  
Sponsored Links
Advertisement
 
post #12 of 55 (permalink) Old 01-11-2017, 07:38 PM Thread Starter
Member
 
Join Date: Jan 2017
Posts: 27
Ah okay then. Car is new (100 miles) so i guess 12v with key on is normal then.
DanWA is offline  
post #13 of 55 (permalink) Old 01-11-2017, 08:10 PM
Forum Elder
 
Array's Avatar
 
Join Date: Jan 2014
Location: SE Michigan
Posts: 4,291
Quote:
Originally Posted by DanWA View Post
Ah okay then. Car is new (100 miles) so i guess 12v with key on is normal then.
Wouldn't go as far as to say normal. Mine reads 12.4V with ignition on and engine not running. However, since your Cherokee is new, it may have been sitting on a lot somewhere and the battery may need additional charging which will be provided as you drive it more; this being longer drives rather than grocery store runs.

2015 White/Black Limited | 3.2-L V6 | Active Drive II | Tech Grp | Lux Grp | Trailer Tow Grp | SafetyTec | Uconect 8.4AN | 9 Speakers | Tonneau Cover | Born 09-06-14 : (( (( (( (( (( (( (( :
Array is offline  
 
post #14 of 55 (permalink) Old 01-11-2017, 08:21 PM Thread Starter
Member
 
Join Date: Jan 2017
Posts: 27
Quote:
Originally Posted by Array View Post
Wouldn't go as far as to say normal. Mine reads 12.4V with ignition on and engine not running. However, since your Cherokee is new, it may have been sitting on a lot somewhere and the battery may need additional charging which will be provided as you drive it more; this being longer drives rather than grocery store runs.
I took a 30 min drive today. Shouldn't that have done the trick?
DanWA is offline  
post #15 of 55 (permalink) Old 01-11-2017, 08:37 PM
Forum Elder
 
Array's Avatar
 
Join Date: Jan 2014
Location: SE Michigan
Posts: 4,291
Quote:
Originally Posted by DanWA View Post

I took a 30 min drive today. Shouldn't that have done the trick?
I'd think so if you were at highway speeds rather than city. These batteries have 6 cells in series at 2.1V each meaning a standalone fully charged battery should come in at 12.6 volts. Put it in a car with the ignition on (a load) and a reading of 12.4 volts makes sense.

My recommendation is to drive it and if you are not experiencing any electrical glitches (electronics not working the way they should) and it still reads 12V after a month, then take it to the dealer for a battery check. It is conceivable there is a weak cell in the battery.

2015 White/Black Limited | 3.2-L V6 | Active Drive II | Tech Grp | Lux Grp | Trailer Tow Grp | SafetyTec | Uconect 8.4AN | 9 Speakers | Tonneau Cover | Born 09-06-14 : (( (( (( (( (( (( (( :
Array is offline  
post #16 of 55 (permalink) Old 01-11-2017, 08:56 PM
Forum Elder
 
Mark_'s Avatar
 
Join Date: Jun 2015
Location: Québec, Canada
Posts: 3,662
Curious about a couple things...

1) @DanWA : do you have the normal EVIC or the premium display (DID) ? DID is on Limited, TH and Overland.
I'm asking because on the EVIC, the voltage scale is difficult to read (in my opinion), and you have to be well acquainted with it to read in-between the static numbers. I know I find mine difficult to interpret.

2) When you test with the ignition *ON*, do you have stuff like the heater blower going ? Rear defroster ? Radio ? Interior lights ? Just for fun, try again and turn everything (you can) off. I'm thinking 12 - 12.2V at rest is possible if you have some high draw stuff running...
Array likes this.

My avatar is the Elder Predator (goes well with my forum status and overall temper )
2015 North (Canada) - V6 - AD1
Cold, Tow, 8.4A, 9 speakers with sub
Mark_ is offline  
post #17 of 55 (permalink) Old 01-11-2017, 09:16 PM Thread Starter
Member
 
Join Date: Jan 2017
Posts: 27
Quote:
Originally Posted by Mark_ View Post
Curious about a couple things...

1) @DanWA : do you have the normal EVIC or the premium display (DID) ? DID is on Limited, TH and Overland.
I'm asking because on the EVIC, the voltage scale is difficult to read (in my opinion), and you have to be well acquainted with it to read in-between the static numbers. I know I find mine difficult to interpret.

2) When you test with the ignition *ON*, do you have stuff like the heater blower going ? Rear defroster ? Radio ? Interior lights ? Just for fun, try again and turn everything (you can) off. I'm thinking 12 - 12.2V at rest is possible if you have some high draw stuff running...
Just the regular I think (Sport). It looks like it's sitting right in between 10 and 14.

When I set the key to run I have everything off. Well except for the screen with radio and stuff in the center which is always on.

Last edited by DanWA; 01-11-2017 at 10:03 PM.
DanWA is offline  
post #18 of 55 (permalink) Old 01-11-2017, 09:23 PM
Forum Elder
 
Mark_'s Avatar
 
Join Date: Jun 2015
Location: Québec, Canada
Posts: 3,662
Quote:
Originally Posted by DanWA View Post
Just the regular I think (Sport). It looks like it's sitting right in between 10 and 12.

When I set the key to run I have everything off. Well except for the screen with radio and stuff in the center which is always on.
Yeah you have the EVIC, like mine.

When I take the Jeep out tomorrow I'll have a look. Getting more snow tonight so definitely going out tomorrow

My avatar is the Elder Predator (goes well with my forum status and overall temper )
2015 North (Canada) - V6 - AD1
Cold, Tow, 8.4A, 9 speakers with sub
Mark_ is offline  
post #19 of 55 (permalink) Old 01-11-2017, 09:43 PM Thread Starter
Member
 
Join Date: Jan 2017
Posts: 27
Quote:
Originally Posted by Mark_ View Post
Yeah you have the EVIC, like mine.

When I take the Jeep out tomorrow I'll have a look. Getting more snow tonight so definitely going out tomorrow
I'd appreciate that! I have the key in ON without starting the engine and I have all AC off. Snap a pic if you can
DanWA is offline  
post #20 of 55 (permalink) Old 01-11-2017, 10:01 PM
Forum Elder
 
Mark_'s Avatar
 
Join Date: Jun 2015
Location: Québec, Canada
Posts: 3,662
Quote:
Originally Posted by DanWA View Post
I'd appreciate that! I have the key in ON without starting the engine and I have all AC off. Snap a pic if you can
One last question : do you mean *ON* as in *RUN* ? Or *ACC* ? I have the regular fob, not the keyless system.

I will take a pic

My avatar is the Elder Predator (goes well with my forum status and overall temper )
2015 North (Canada) - V6 - AD1
Cold, Tow, 8.4A, 9 speakers with sub
Mark_ is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the 2014+ Jeep Cherokee Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



  Similar Threads
Thread Thread Starter Forum Replies Last Post
Annoying beeping whilst driving Jeep12345 2014+ Jeep Cherokee General Discussion 11 07-28-2016 09:40 PM
Battery voltage is low Nielcoop 2014+ Jeep Cherokee General Discussion 5 06-07-2016 05:44 PM
Low Battery Voltage & Car will not start gjdiste 2014+ Jeep Cherokee General Discussion 1 12-30-2015 06:35 PM
Low voltage battery light on TH2014 Electronics, Audio, and Lighting 9 11-26-2015 11:01 AM
Low Battery in EVIC muengineer Electronics, Audio, and Lighting 6 09-04-2014 07:20 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On