Battery died and is acting up? - Page 3 - 2014+ Jeep Cherokee Forums
User Tag List

 22Likes
Reply
 
LinkBack Thread Tools
post #21 of 50 (permalink) Old 02-03-2017, 04:29 PM
Forum Elder
 
Mark_'s Avatar
 
Join Date: Jun 2015
Location: Québec, Canada
Posts: 4,043
Ok one more about FCA batteries...

Found a company named Magneti Marelli, an Italian (well...) company with offices everywhere. They make (or rather distribute) Mopar batteries :
http://www.discountautoparts.com/cat...par/bbah7800aa
(^^That's the KL AGM battery).

Magneti Marelli was purchased by... drum roll... Sergio. Yeah that Sergio (FCA boss).

Found another site, not really current but good enough, which lists battery brands and who makes them, and Magneti Marelli falls under the Exide group...
Reading more and trying to understand who makes what and who went into joint ventures with whom... is a very complex mission. One thing I did find is Johnson Controls are in a joint venture with FCA for car parts other than batteries in the Serbian market... Yeah, the *global market* thing is no joke...

I still haven't found a perfect match for my 700CCA AGM yet, but I know it falls under the Exide group (also JC ??).
One thing I do know : if/when I need a new battery, I'm going with this one (840CCA group 94R) :
http://buy.northstarbattery.com/p/nsb-agm94r-l4-battery

Or... if I find a slightly larger one fits in the tray and doesn't short out against the hood above it, this one :
http://buy.northstarbattery.com/p/ns...6ebc21f29dcf40
(not that much more CCAs, but a nice reserve capacity increase... This group 27F battery is 1.4" taller than a group 94R)

My avatar is the Elder Predator (goes well with my forum status and overall temper )
2015 North (Canada) - V6 - AD1
Cold, Tow, 8.4A, 9 speakers with sub

Last edited by Mark_; 02-03-2017 at 04:47 PM. Reason: oops again
Mark_ is offline  
Sponsored Links
Advertisement
 
post #22 of 50 (permalink) Old 02-03-2017, 05:52 PM
Member
 
Join Date: Feb 2017
Posts: 6
Garage
Mopar is using Interstate batteries for their battery supplier, at least the 3-36 warranty will cover your problem. all manufactures require a battery test slip to be attached to the hard copy if that's not attached they will be charged back for the repair. that's why it takes so long to get a battery replaced under warranty.
racerx1986 is offline  
post #23 of 50 (permalink) Old 02-03-2017, 05:55 PM Thread Starter
Enthusiast Member
 
Join Date: Nov 2016
Posts: 191
Quote:
Originally Posted by Mark_ View Post
That's good news !

Oh and sorry for the mega off-topic slide I took there, with all that battery stuff... Guess it fascinates me

But anyway, if you ever need a new battery outside warranty, you have some tips on which way to go here, haha.

Good luck with the 8.4 project
Uhhh, this might not be over yet actually. while the engine is running and while idle, the voltage drops a tiny tiny bit below 14 on the EVAC screen about 2-3 times every minute. Also when I first start the Jeep I still cannot rev at all, I have to put it in drive to do it. Gonna upload a video later tonight, ugh.

Sent from my ONEPLUS A3000 using Tapatalk

2014 Cherokee Sport AWD 2.4L I4 16V
Mileage: 27k+, Bought @ 18K in 2016
Issues: 2 = Ignition Coil & Battery went bad, Both replaced under warranty

Status: Running perfectly


Upgrades:
* Uconnect 8.4 RA4 w/ Nav
* Interior LED foot well lights
shemmar360 is offline  
 
post #24 of 50 (permalink) Old 02-04-2017, 11:31 AM
Forum Elder
 
Mark_'s Avatar
 
Join Date: Jun 2015
Location: Québec, Canada
Posts: 4,043
Quote:
Originally Posted by racerx1986 View Post
Mopar is using Interstate batteries for their battery supplier, at least the 3-36 warranty will cover your problem. all manufactures require a battery test slip to be attached to the hard copy if that's not attached they will be charged back for the repair. that's why it takes so long to get a battery replaced under warranty.
Thanks. And just FYI :
Quote:
Interstate Battery System of America, Inc., a.k.a. Interstate Batteries, is a privately owned company that markets automotive batteries manufactured by Johnson Controls and others through independent distributors. The company is headquartered in Dallas, Texas,
Source : https://en.wikipedia.org/wiki/Interstate_Batteries

Quote:
Originally Posted by shemmar360 View Post
Uhhh, this might not be over yet actually. while the engine is running and while idle, the voltage drops a tiny tiny bit below 14 on the EVAC screen about 2-3 times every minute. Also when I first start the Jeep I still cannot rev at all, I have to put it in drive to do it. Gonna upload a video later tonight, ugh.
Uh-oh... Well, voltage at or just below 14V can be / should be Ok, but the revving thing is very weird. Keep us posted...

My avatar is the Elder Predator (goes well with my forum status and overall temper )
2015 North (Canada) - V6 - AD1
Cold, Tow, 8.4A, 9 speakers with sub
Mark_ is offline  
post #25 of 50 (permalink) Old 02-04-2017, 11:58 AM
Enthusiast Member
 
Bigtsr's Avatar
 
Join Date: Apr 2016
Location: Burlington,Ontario,Canada
Posts: 167
Garage
"Also when I first start the Jeep I still cannot rev at all, I have to put it in drive to do it."


Chrysler products have had built in "REV LIMITERS" for
Park/\Neutral for ages , this is normal.
Mark_, mmahamm and shemmar360 like this.

Bigtsr is offline  
post #26 of 50 (permalink) Old 02-08-2017, 07:41 AM
Enthusiast Member
 
Join Date: Dec 2013
Location: Minne"snow"ta
Posts: 139
Garage
This just happened to me yesterday. Monday night all good. Tuesday rolls around and I work from home. Time to pick up my son from school and the Jeep won't turnover - no slow turn, just nothing. I grab my battery charger with jump-start capability and jump it. History would tell me that on my drive to school about 5 miles away I should get a charge. Shut the Jeep down and grab my son and try to start: dead. No turnover. Nothing.

My wife is close and I jump-start the Jeep again and drive towards my Jeep dealer 5 miles away. Needless to say, when I shut it off at the shop, it didn't start. They were going to test the battery over the night - and thanks to my Max Care I signed up for less than a week ago, I got a loaner in the meantime.

So, either the battery like this thread - or the alternator? Guess we shall see.

2014 Cherokee TrailHawk - Bright White / Black Interior
3.2L V6 (EHB) / Tow (AHT) / 9-S & S (RC3) / Uconnect + NAV (RA4) / Black Hood Decal (MYA) / C&C (AFB) / Cold Weather (ADE)
KrazyAmateur is offline  
post #27 of 50 (permalink) Old 02-08-2017, 01:04 PM
Premium Member
 
Join Date: Apr 2016
Posts: 382
Quote:
Originally Posted by KrazyAmateur View Post
This just happened to me yesterday. Monday night all good. Tuesday rolls around and I work from home. Time to pick up my son from school and the Jeep won't turnover - no slow turn, just nothing. I grab my battery charger with jump-start capability and jump it. History would tell me that on my drive to school about 5 miles away I should get a charge. Shut the Jeep down and grab my son and try to start: dead. No turnover. Nothing.

My wife is close and I jump-start the Jeep again and drive towards my Jeep dealer 5 miles away. Needless to say, when I shut it off at the shop, it didn't start. They were going to test the battery over the night - and thanks to my Max Care I signed up for less than a week ago, I got a loaner in the meantime.

So, either the battery like this thread - or the alternator? Guess we shall see.
Hi KrazyAmateur,

Sorry to hear about this! I'd be happy to follow up with your dealership for you if needed, just PM our page with your VIN and let me know.

Andrea
Jeep Social Care Specialist
JeepCares is online now  
post #28 of 50 (permalink) Old 02-08-2017, 01:41 PM
Forum Elder
 
Mark_'s Avatar
 
Join Date: Jun 2015
Location: Québec, Canada
Posts: 4,043
Quote:
Originally Posted by KrazyAmateur View Post
This just happened to me yesterday. Monday night all good. Tuesday rolls around and I work from home. Time to pick up my son from school and the Jeep won't turnover - no slow turn, just nothing. I grab my battery charger with jump-start capability and jump it. History would tell me that on my drive to school about 5 miles away I should get a charge. Shut the Jeep down and grab my son and try to start: dead. No turnover. Nothing.

My wife is close and I jump-start the Jeep again and drive towards my Jeep dealer 5 miles away. Needless to say, when I shut it off at the shop, it didn't start. They were going to test the battery over the night - and thanks to my Max Care I signed up for less than a week ago, I got a loaner in the meantime.

So, either the battery like this thread - or the alternator? Guess we shall see.
Sorry to hear about that...

To rule out the alternator we'd need voltage readings while the Jeep is running, but no biggie, the dealership should have no problem identifying the culprit. Battery is the statistical choice here, probably a bad cell as we've seen on quite a few regular wet (non AGM) 2014 batteries.

Don't be shy to ask Andrea for extra assistance, if needed. Keep us posted
JeepCares likes this.

My avatar is the Elder Predator (goes well with my forum status and overall temper )
2015 North (Canada) - V6 - AD1
Cold, Tow, 8.4A, 9 speakers with sub
Mark_ is offline  
post #29 of 50 (permalink) Old 02-08-2017, 02:03 PM
Member
 
Jeepers.Creepers's Avatar
 
Join Date: Dec 2016
Location: Nevada
Posts: 16
Quote:
Originally Posted by Mark_ View Post
I forget if the battery is covered under the basic 3/36 warranty, I think it is, so you should be Ok

It should be covered. I had the same issue I just took it to the dealership they ran tests and got a new battery. Have to take advantage when under warranty and get those problems fixed asap.



Sent from my iPhone using Tapatalk
Mark_ likes this.

FIRST TIME OWNER O llllllll O
Jeepers.Creepers is offline  
post #30 of 50 (permalink) Old 02-08-2017, 02:39 PM
Enthusiast Member
 
Join Date: Dec 2013
Location: Minne"snow"ta
Posts: 139
Garage
Thanks everyone! The dealer called with an update. The battery indeed failed when they were testing it so that is all replaced now. They are going to tackle the TSBs for cold weather squealing (KL_07_002_15 and KL_07_001_16) and she should be ready to go tonight or tomorrow. I'm just barely under the 36K warranty, so phew! Glad I got it done now - doesn't sounds like TSBs are covered under MaxCare, but I did get a loaner out of the deal.
Mark_ and JeepCares like this.

2014 Cherokee TrailHawk - Bright White / Black Interior
3.2L V6 (EHB) / Tow (AHT) / 9-S & S (RC3) / Uconnect + NAV (RA4) / Black Hood Decal (MYA) / C&C (AFB) / Cold Weather (ADE)
KrazyAmateur is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the 2014+ Jeep Cherokee Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



  Similar Threads
Thread Thread Starter Forum Replies Last Post
Key Fob acting up jkjhooks Electronics, Audio, and Lighting 17 01-05-2017 03:30 PM
Blue ink on positive battery terminal? Does your jeeps battery have that? XtremeModder Engine and Technical Discussion 12 04-20-2016 10:45 AM
R01 Update Acting Wonky davelja 2014+ Jeep Cherokee General Discussion 106 07-05-2015 02:09 PM
Fob died? (not battery) RockyMtnHawk 2014+ Jeep Cherokee General Discussion 3 05-02-2015 06:20 PM
Engine harness to be replaced--Kee acting crazy! Shorts360 2014+ Jeep Cherokee General Discussion 9 05-03-2014 08:59 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On