CEL after Airaid CAI install - 2014+ Jeep Cherokee Forums
User Tag List

 
LinkBack Thread Tools
post #1 of 3 (permalink) Old 05-19-2017, 01:27 PM Thread Starter
Enthusiast Member
 
ern3's Avatar
 
Join Date: Aug 2014
Location: Chicago Burbs, IL / Valley of the sun, AZ
Posts: 133
CEL after Airaid CAI install

Any one have a CEL after CAI install? I hooked up the temp sensor after I started it... Oops. Does the light clear after awhile? Thx

~St0rmtr00p3r ~

'14 Bright White Limited 4X4 3.2 V6 - Lux Tech Fully Loaded
LED lighting ~ Tint all around ~ Custom hood decal
ern3 is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 05-19-2017, 06:13 PM
Hardcore Member
 
tbrou6229's Avatar
 
Join Date: Feb 2016
Location: Asheville, North Carolina
Posts: 852
Garage
Quote:
Originally Posted by ern3 View Post
Any one have a CEL after CAI install? I hooked up the temp sensor after I started it... Oops. Does the light clear after awhile? Thx
The light usually will clear after a while; you can force a reset by disconnecting the battery and leaving it unconnected for 30min or so. When you reconnect the battery and restart the vehicle, drive around for a few minutes (20-30?) Don't just start the vehicle and turn it off.

Sent from my XT1585 using Tapatalk

White 2016 KL Trailhawk 3.2 V6
SafetyTec and Tech Packs * Factory Tow * CommandView Panoramic Sunroof * 9 Speakers With Sub * Black Painted Aluminum Wheels * uConnect 8.4 NAV

~Mods List~ (In Progress!)
HazardSky 1.5" Lift * RRO Steprails * XenonDepot Xtreme HID (4300K Headlights) * 5000k LED Fog Lights * Bison 64" Cargo Basket * Lots of Pretty Lights!

The First Family Member...
Brilliant Black 2015 KL Latitude 3.2 V6, ADI
See HERE for Mod List!
tbrou6229 is offline  
post #3 of 3 (permalink) Old 05-19-2017, 06:19 PM Thread Starter
Enthusiast Member
 
ern3's Avatar
 
Join Date: Aug 2014
Location: Chicago Burbs, IL / Valley of the sun, AZ
Posts: 133
Thank you sir!
Quote:
Originally Posted by tbrou6229 View Post
The light usually will clear after a while; you can force a reset by disconnecting the battery and leaving it unconnected for 30min or so. When you reconnect the battery and restart the vehicle, drive around for a few minutes (20-30?) Don't just start the vehicle and turn it off.

Sent from my XT1585 using Tapatalk

~St0rmtr00p3r ~

'14 Bright White Limited 4X4 3.2 V6 - Lux Tech Fully Loaded
LED lighting ~ Tint all around ~ Custom hood decal
ern3 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the 2014+ Jeep Cherokee Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



  Similar Threads
Thread Thread Starter Forum Replies Last Post
New CAI installed 11bmopar Engine and Technical Discussion 48 07-01-2016 08:37 AM
CEL Again Jknappen Engine and Technical Discussion 19 05-19-2016 08:47 PM
Xenon Depot Xtreme HID Install w/Install Photos LTHG Electronics, Audio, and Lighting 31 01-16-2016 08:23 PM

WANT TO BUY

Used CAI
ern3 Cherokee (KL) Parts & Accessories 0 12-26-2015 12:55 AM
CAI for 2.4L 709TrailHawk Engine and Technical Discussion 5 07-10-2014 11:17 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On