heater not maintaining temp (my story so far) - Page 3 - 2014+ Jeep Cherokee Forums
User Tag List

 34Likes
Reply
 
LinkBack Thread Tools
post #21 of 71 (permalink) Old 02-25-2016, 06:53 PM Thread Starter
Enthusiast Member
 
osirisdean's Avatar
 
Join Date: Jan 2015
Location: middle georgia
Posts: 159
Garage
disappointing update: i am back to square one. replacing the AC Control Head DOES NOT WORK. details:

car parked outside all day
57 degrees outside
hopped in car to commute home, set temp to 70
car pumped warm air
after a while, air started getting cold again
even cranking up to 78 degrees and fan on speed 4, still pumping out cool/cold air
all interstate driving, very little change in speed, for what it's worth

here's a weird thing i noticed, though: when i exited the interstate and stopped at a light, the auto-turn-the-engine-off feature turned the car off. and *immediately* the heat kicked on. had me sweating in seconds. (still set to 78, no changes done by me.) it's as if cycling power to the car reset the temperature gauge or something.

ugh. im pretty disappointed im going to have to reopen this star case. thermostats are *not* that complicated, so i have no idea why chrysler cant get it right.
Array likes this.

"We're not here because we're free; we're here because we're not free." -- Smith
2015 Cherokee Latitude 3.2L V6 FWD

comfort/convenience group, tow group, 8.4A uconnect
build date: november, 2014

Last edited by osirisdean; 02-25-2016 at 07:07 PM.
osirisdean is offline  
Sponsored Links
Advertisement
 
post #22 of 71 (permalink) Old 02-25-2016, 08:47 PM
Member
 
Join Date: May 2015
Posts: 1
And here I thought it was just me. I have pretty much resigned myself to the fact that the transmission will NEVER be fixed, and now this. I'm only noticing mine because normally my work commute was 5 minutes at the most. I have a new job and the commute is now 45 minutes...that makes a lot of difference when the outside temp is below freezing and your vehicle thinks you've set your temp to 72 for the **** of it. Cranking it to 76 or above usually only helps for a short time, and then here comes the ice cold air again. How hard is it for engineers to get their crap together? We pay too much for these vehicles for them to not work properly. My previous vehicle was a 2008 Camry SE, so apparently I have a knack for this and wish I didn't.
osirisdean likes this.
paluma0268 is offline  
post #23 of 71 (permalink) Old 02-25-2016, 10:57 PM
Forum Elder
 
Array's Avatar
 
Join Date: Jan 2014
Location: SE Michigan
Posts: 4,215
Quote:
Originally Posted by osirisdean View Post
disappointing update: i am back to square one. replacing the AC Control Head DOES NOT WORK. .... im pretty disappointed im going to have to reopen this star case. thermostats are *not* that complicated, so i have no idea why chrysler cant get it right.
Thanks for the feedback. There is definitely something wrong. Appreciate you reopening the star case. With your persistence maybe FCA will figure out what's wrong and we'll all benefit through a TSB.
osirisdean likes this.

2015 White/Black Limited | 3.2-L V6 | Active Drive II | Tech Grp | Lux Grp | Trailer Tow Grp | SafetyTec | Uconect 8.4AN | 9 Speakers | Tonneau Cover | Born 09-06-14 : (( (( (( (( (( (( (( :
Array is offline  
post #24 of 71 (permalink) Old 02-25-2016, 11:01 PM Thread Starter
Enthusiast Member
 
osirisdean's Avatar
 
Join Date: Jan 2015
Location: middle georgia
Posts: 159
Garage
my wife confirmed it when we went out to dinner this evening. set to 73, it blew hot for about 10 minutes before starting to blow cooler air again. i am not a happy camper.

yeah, tomorrow i plan on reopening the case. there's no excuse for this, and i say that as an engineer. my wife's 10 year old ford edge can maintain temperature (with the same type of numerical temperature settings), there's no reason a year old car with brand new parts shouldn't be able to.

"We're not here because we're free; we're here because we're not free." -- Smith
2015 Cherokee Latitude 3.2L V6 FWD

comfort/convenience group, tow group, 8.4A uconnect
build date: november, 2014
osirisdean is offline  
post #25 of 71 (permalink) Old 02-26-2016, 01:29 AM
Forum Elder
 
Array's Avatar
 
Join Date: Jan 2014
Location: SE Michigan
Posts: 4,215
Quote:
Originally Posted by osirisdean View Post
my wife confirmed it when we went out to dinner this evening. set to 73, it blew hot for about 10 minutes before starting to blow cooler air again. i am not a happy camper.

yeah, tomorrow i plan on reopening the case. there's no excuse for this, and i say that as an engineer. my wife's 10 year old ford edge can maintain temperature (with the same type of numerical temperature settings), there's no reason a year old car with brand new parts shouldn't be able to.
Something's screwy about it. Cold outside and the temp is set to 72° F and then the AC comes on with zero heat mixed in??? Happens to us all the time. I'm guessing it's a program bug. You know, what worries me is it's cold in Auburn Hills, Michigan and there are tons of these KLs running around headquarters. Wouldn't you think by now that some upper management types would be mad and have it fixed by now?
osirisdean likes this.

2015 White/Black Limited | 3.2-L V6 | Active Drive II | Tech Grp | Lux Grp | Trailer Tow Grp | SafetyTec | Uconect 8.4AN | 9 Speakers | Tonneau Cover | Born 09-06-14 : (( (( (( (( (( (( (( :
Array is offline  
post #26 of 71 (permalink) Old 02-26-2016, 09:02 AM Thread Starter
Enthusiast Member
 
osirisdean's Avatar
 
Join Date: Jan 2015
Location: middle georgia
Posts: 159
Garage
generally speaking, when i first get in and turn it on (and have the temp set somewhere between 70 and 73), the jeep will crank warm air. it'll start as warm, then once I hit the interstate (less than a mile from my house), it'll get a little warmer.


then, 15~20 minutes of interstate driving later, it is pumping out very noticeably cooler air. sometimes lukewarm, often cool, sometimes wtf-it's-50-outside-and-my-heat-is-cranked-to-75-why-am-i-shivering-in-my-car cool air.


i agree, it has to be either a programming bug or a problem with the cabin thermometer. (and i don't think it's the latter, but i cant articulate my reasoning well just yet..)

"We're not here because we're free; we're here because we're not free." -- Smith
2015 Cherokee Latitude 3.2L V6 FWD

comfort/convenience group, tow group, 8.4A uconnect
build date: november, 2014
osirisdean is offline  
post #27 of 71 (permalink) Old 02-26-2016, 09:19 AM Thread Starter
Enthusiast Member
 
osirisdean's Avatar
 
Join Date: Jan 2015
Location: middle georgia
Posts: 159
Garage
previous case (#28641983, for what it's worth) hadn't been closed, i guess since it's only been a couple weeks. so they are going to escalate it to case management again, and i'll be contacted within the next couple business days.


here we go again. :/


(at least Chrysler seems interested in helping, i will give them that.)

"We're not here because we're free; we're here because we're not free." -- Smith
2015 Cherokee Latitude 3.2L V6 FWD

comfort/convenience group, tow group, 8.4A uconnect
build date: november, 2014
osirisdean is offline  
post #28 of 71 (permalink) Old 02-26-2016, 10:54 AM
Forum Elder
 
Array's Avatar
 
Join Date: Jan 2014
Location: SE Michigan
Posts: 4,215
Another thing...

Don't know if yours is the same, but mine works fine when it's warm out. This is the second winter it's been doing this. So it is a problem that existed from the start.
SDBio likes this.
Array is offline  
post #29 of 71 (permalink) Old 02-27-2016, 10:53 AM Thread Starter
Enthusiast Member
 
osirisdean's Avatar
 
Join Date: Jan 2015
Location: middle georgia
Posts: 159
Garage
Quote:
Originally Posted by Array View Post
Another thing...

Don't know if yours is the same, but mine works fine when it's warm out. This is the second winter it's been doing this. So it is a problem that existed from the start.
yeah, i dont recall ever being annoyed with it in the summer, seems to pump cold air just fine.

"We're not here because we're free; we're here because we're not free." -- Smith
2015 Cherokee Latitude 3.2L V6 FWD

comfort/convenience group, tow group, 8.4A uconnect
build date: november, 2014
osirisdean is offline  
post #30 of 71 (permalink) Old 03-01-2016, 02:50 PM Thread Starter
Enthusiast Member
 
osirisdean's Avatar
 
Join Date: Jan 2015
Location: middle georgia
Posts: 159
Garage
minor update: spoke with new case manager, who told me to take the jeep back to the dealership for more troubleshooting. i asked if there was anything Chrysler could research on their end without a trip to the dealership (not that i don't want to bring it back; i just don't know what they'll find that they couldn't find the first time around), but he said all they can do is have me bring it in and tool around on it some more.


jeep returns to the dealership tomorrow afternoon.


at least he (star case manager) agreed that Chrysler will cover the cost of my rental again.

"We're not here because we're free; we're here because we're not free." -- Smith
2015 Cherokee Latitude 3.2L V6 FWD

comfort/convenience group, tow group, 8.4A uconnect
build date: november, 2014
osirisdean is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the 2014+ Jeep Cherokee Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



  Similar Threads
Thread Thread Starter Forum Replies Last Post
A heartwarming story Craigman TH 2014+ Jeep Cherokee General Discussion 9 11-19-2015 11:45 PM
An All-Too-Familiar Story SoCal Bob Transmission Discussion 3 03-29-2015 02:07 PM
Tranny Temp and Coolant temp not showing up on guage JTBOkee 2014+ Jeep Cherokee General Discussion 1 01-22-2015 01:46 PM
Great Story Here zzjdzz The JCC Lounge 6 06-11-2014 01:52 PM
Funny Story NorthCoastie 2014+ Jeep Cherokee General Discussion 2 02-27-2014 08:51 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On