Brakes or Rotor problem? Need some advice - 2014+ Jeep Cherokee Forums
User Tag List

 3Likes
  • 1 Post By Jeeep187
  • 2 Post By Bigtsr
 
LinkBack Thread Tools
post #1 of 6 (permalink) Old 05-18-2017, 01:50 PM Thread Starter
Member
 
Join Date: May 2017
Posts: 3
Brakes or Rotor problem? Need some advice

I noticed when I brake from higher speeds with a good amount of pressure, I get some judder (like when rotors are warped). This only happens when they are very warm or been driving a while. But mostly hard to detect unless high speed harder braking.
I have a 2015 Cherokee Trailhawk with 29,000 kilometers on it.

Since I had the vehicle, I know that the brakes are not very good...worst I've had, never really had the ABC going, but if it's wet or have to brake suddenly, I will slide a little out of control, even from 30 km/h, so have always been weary about braking the trailhawk as it has the worst stopping power in all the vehicle I have owned over 25 years.

I read some posts about this, some have mentioned a 12 month 24000? Warranty, and possibly covered under bumper to bumper if there's an issue like what I believe I might have.

What do you think of the picture of my front right rotor for example. I've never seen contact like this from the pad. Don't know what's going on, and if it might be covered.

I called my Jeep dealer in surrey BC Canada, the service manager told me that there is no warranty whatsoever on brakes or rotors, since they are a wear and tear item. But to pay $40 for an inspection and there is a possibility they might do something after looking at it.

What do you pros think is going on....have u seen wear on the rotor like this before?

Thank you!!!

First pic is front right
Second is front left.
Third is right rear
Fourth is left rear.

Both rights seems to not have full coverage. The front is only using like half of the rotor. Also the rear rotors are smaller than the front which you probably know.
The rear left had some weird etching in them.


Sent from my SM-G935W8 using Tapatalk
Jeeep187 is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old 05-18-2017, 02:02 PM
Enthusiast Member
 
Bigtsr's Avatar
 
Join Date: Apr 2016
Location: Burlington,Ontario,Canada
Posts: 167
Garage
Not a warranty item as they are consumables and mileage
is barely relevant when you reach 29,000 km.
First pic really has a problem spend the money
for safety sake.

Bigtsr is offline  
post #3 of 6 (permalink) Old 05-18-2017, 02:15 PM
Member
 
purelithium's Avatar
 
Join Date: May 2017
Location: Ottawa, Ontario, Canada
Posts: 30
Garage
You definitely need to have everything looked at. you've got some uneven pad wear, looks like the pad edges are no longer in contact, most noticeably in the first pic.

Your dealer is wrong. Brakes are covered for 1 yr/20000km (see here: http://www.fcacanada.ca/owners/en/ma...B-070A-1st.pdf). Also, Sounds like you have had a braking issue for a long time, but didn't do anything about it when it was in warranty.

purelithium

2016 North 3.2

Pro Patria
purelithium is offline  
 
post #4 of 6 (permalink) Old 05-18-2017, 02:18 PM Thread Starter
Member
 
Join Date: May 2017
Posts: 3
Quote:
Originally Posted by Bigtsr View Post
Not a warranty item as they are consumables and mileage
is barely relevant when you reach 29,000 km.
First pic really has a problem spend the money
for safety sake.
Yes, will be fixed ASAP.
Does anyone know why a pad would only contact the centre of the rotor like this?

I found out after I bought it..new...that it was actually sold to someone else first, who then brought it back and the dealer had to take it. It was something to do with the first owner being told he could tow the mac amount; then after he was towing a large camper, realized that the 4 cylinder is not rated for the higher gvw, so Somehow forced dealer to take it. They had reset the odometer to 0 as well, so I didn't know until it I already owned it and found out after the first oil change.

I don't know if it could have been in a small accident or maybe hit the curb really hard by the last guy?

Wondering what could cause this. Would rather do the work myself instead of over $100 per hour by the dealer and God know what other fake charges. But don't want a new setup to cause the same thing if it's a bent frame, control arm, etc etc. Possibly causing it.

Side note, when I went to get a hitch from them, they quoted me 8 hours, plus shop tools, and other fees....apparently a special guy who there are only 2 in BC that could install the new bumper/hitch and only he had the skill to cut the fascia hole etc....so was over $1000 for just the install!!
Luckily found this site back then, followed the steps someone posted and did it myself in 45 minutes. So don't really trust the dealer when they lie and overcharge to such a massive extent.
Also went to 2 other dealers afterwards and the first contacted them and they all repeated the same cost structure and the BS about a "special guy" that needs to be brought in to cut the hole. (It's just a **** knockout a child could do with a simple push of their hand)

Sent from my SM-G935W8 using Tapatalk
Jeeep187 is offline  
post #5 of 6 (permalink) Old 05-18-2017, 02:23 PM Thread Starter
Member
 
Join Date: May 2017
Posts: 3
Quote:
Originally Posted by purelithium View Post
You definitely need to have everything looked at. you've got some uneven pad wear, looks like the pad edges are no longer in contact, most noticeably in the first pic.

Your dealer is wrong. Brakes are covered for 1 yr/20000km (see here: http://www.fcacanada.ca/owners/en/ma...B-070A-1st.pdf). Also, Sounds like you have had a braking issue for a long time, but didn't do anything about it when it was in warranty.
Yeah, it was brand new, so just figured that's how they brake. Also had inferior shifting and take off lag...and super loud fan. I had asked about the shifting and fan but was told that's how vehicle was made.
Also there's a small grind from the back end and a loss of power for 2 seconds when you go over a speed bump, but was told that's normal as well.

I'll go pay the $40 and see if they might cover any repairs if needed, it may actually be a manufacturing issue at time of build...who knows.
Just weird how only the center makes contact....offset, it would be the top or bottom..
But the middle!? That's weird.

Sent from my SM-G935W8 using Tapatalk
scottb likes this.
Jeeep187 is offline  
post #6 of 6 (permalink) Old 05-18-2017, 02:23 PM
Enthusiast Member
 
Bigtsr's Avatar
 
Join Date: Apr 2016
Location: Burlington,Ontario,Canada
Posts: 167
Garage
Reset the odometer???
Illegal in most area that I know of , I think it's a bit late
certainly should be questioned.
Mark_ and 04Freedom like this.

Bigtsr is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the 2014+ Jeep Cherokee Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



  Similar Threads
Thread Thread Starter Forum Replies Last Post
Rear rotor replacement? IRSmart Wheels, Tires, Brakes, and Suspension 15 05-27-2017 11:08 PM
What's up with my rear rotor? Shoulder Wheels, Tires, Brakes, and Suspension 11 05-09-2017 04:32 PM
Looking for advice - doing brakes for the first time eorlas Wheels, Tires, Brakes, and Suspension 1 12-26-2016 09:23 AM
Rotor specs for 2014 kl zmttoxics Wheels, Tires, Brakes, and Suspension 4 11-02-2015 09:47 AM
New TH with Warped Rotor- yikes! CaptainRuss New Member Introductions 10 04-25-2014 10:05 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On