XenonDepot HID kit step by step installation guide - Page 12 - 2014+ Jeep Cherokee Forums
User Tag List

 32Likes
Reply
 
LinkBack Thread Tools
post #111 of 120 (permalink) Old 02-22-2017, 03:48 PM
Member
 
Jakeg's Avatar
 
Join Date: Oct 2016
Location: Phoenix, AZ
Posts: 21
Garage
Quote:
Originally Posted by XenonDepot View Post
@Jakeg - The 2016 Cherokee uses either 9005 or 9012 bulbs. Can you please send me a PM with your order info so that I can pull it up and review?
PM sent! Thank you!

2016 Jeep Cherokee Trailhawk
Mango Tango
V6, Comfort and Convenience, Nav
Hazard Sky Lift
Xenon Depot HIDs
K&N Cold Air Intake
9 Speaker JL Audio Sound System
Jakeg is offline  
Sponsored Links
Advertisement
 
post #112 of 120 (permalink) Old 02-24-2017, 03:00 PM
Enthusiast Member
 
shayne10's Avatar
 
Join Date: Jun 2016
Location: Texas
Posts: 101
has anyone seen these?


Sent from my iPhone using Tapatalk
Duke2015 likes this.
shayne10 is offline  
post #113 of 120 (permalink) Old 02-26-2017, 12:00 AM
Member
 
ambiguity's Avatar
 
Join Date: Apr 2016
Posts: 49
Quote:
Originally Posted by shayne10 View Post
has anyone seen these?


Sent from my iPhone using Tapatalk
I think they are still designed for halogen bulbs.

2016 Jeep Altitude
Black on black
Cold Weather Package
Comfort & Convenience Package
Safety Package
Panoramic Sun Roof
Navigation
Tow Package
ambiguity is offline  
 
post #114 of 120 (permalink) Old 02-26-2017, 12:03 AM
Member
 
ambiguity's Avatar
 
Join Date: Apr 2016
Posts: 49
Quote:
Originally Posted by Mark_ View Post
Roger that.

Well I had to zip tie one of my connectors (9012 in my case) because I broke the little flimsy clips on one of the Jeep's original connector while pulling it from the halogen bulb. Fitment was good but a few bumps and I would've been without juice to that bulb real quick. I think you *should* be fine with a zip tie, but I understand the anx...
So I replaced the pins in the connector and they no longer slip (to the PWM module). I am still having a bulb out issue with the passenger side though. When I connect it backwards + to -, - to + it will work then work the normal way + to +, - to -. I was in a drive-thru and turned them off so I didn't bother the car in front of me and when I turned them back on the bulb was out again so I did the same thing... backwards first and it worked until I got home. Not really sure what is going on here.

2016 Jeep Altitude
Black on black
Cold Weather Package
Comfort & Convenience Package
Safety Package
Panoramic Sun Roof
Navigation
Tow Package
ambiguity is offline  
post #115 of 120 (permalink) Old 02-26-2017, 12:53 AM
Forum Elder
 
Mark_'s Avatar
 
Join Date: Jun 2015
Location: Québec, Canada
Posts: 4,014
Quote:
Originally Posted by ambiguity View Post
So I replaced the pins in the connector and they no longer slip (to the PWM module). I am still having a bulb out issue with the passenger side though. When I connect it backwards + to -, - to + it will work then work the normal way + to +, - to -. I was in a drive-thru and turned them off so I didn't bother the car in front of me and when I turned them back on the bulb was out again so I did the same thing... backwards first and it worked until I got home. Not really sure what is going on here.
Well that's no good... Give XD a call. I think I recall a few members with 9005 kits having this problem, as if one PWM module isn't as efficient as it should be, to prevent the bulb out error.

My avatar is the Elder Predator (goes well with my forum status and overall temper )
2015 North (Canada) - V6 - AD1
Cold, Tow, 8.4A, 9 speakers with sub
Mark_ is offline  
post #116 of 120 (permalink) Old 02-26-2017, 01:28 AM
Member
 
ambiguity's Avatar
 
Join Date: Apr 2016
Posts: 49
Quote:
Originally Posted by Mark_ View Post
Quote:
Originally Posted by ambiguity View Post
So I replaced the pins in the connector and they no longer slip (to the PWM module). I am still having a bulb out issue with the passenger side though. When I connect it backwards + to -, - to + it will work then work the normal way + to +, - to -. I was in a drive-thru and turned them off so I didn't bother the car in front of me and when I turned them back on the bulb was out again so I did the same thing... backwards first and it worked until I got home. Not really sure what is going on here.
Well that's no good... Give XD a call. I think I recall a few members with 9005 kits having this problem, as if one PWM module isn't as efficient as it should be, to prevent the bulb out error.
Yep... I am in contact with them after complaining about the factor harness. I feel they want to know what the problem is too based on the back and forth emails.

Last edited by ambiguity; 02-26-2017 at 07:23 PM.
ambiguity is offline  
post #117 of 120 (permalink) Old 02-26-2017, 10:12 AM
Forum Elder
 
Mark_'s Avatar
 
Join Date: Jun 2015
Location: Québec, Canada
Posts: 4,014
Quote:
Originally Posted by ambiguity View Post
Yep... I am in contact with them after complaining about the factor harness. I feel they want to know what the problem is too based on the back and forth emails.

BTW: I talked to my brother-in-law who is a state trooper and found out that after market hids are illegal (and I did some post purchase searches)... he said they'll pull me over cuz they might think I have my brights on and just show them I don't. Hehe. I pointed them down a little bit and haven't been flashed since.
Keep us posted on the situation, I'm sure this will help make the kits better, at least the 9005 kits because the 9012 kits seem to be pretty consistantly good. Just speculation but it could have something to do with the extra load from 9005s (65W each for halogens) compared to the 9012s (55W each).

As far as being pulled over : sure it can happen if you have your low beams in oncoming faces. But if the aim is right, having projectors kinda lowers suspicion, and also since similar projectors on some KLs come with xenon bulbs, there isn't that horrible HID in reflectors visual assault even with a low aim...

My avatar is the Elder Predator (goes well with my forum status and overall temper )
2015 North (Canada) - V6 - AD1
Cold, Tow, 8.4A, 9 speakers with sub
Mark_ is offline  
post #118 of 120 (permalink) Old 03-03-2017, 12:16 AM
Member
 
ambiguity's Avatar
 
Join Date: Apr 2016
Posts: 49
Trying to figure out what this shadow is... is it the bar on the HID bulb? I don't see it on the passenger side.
Attached Thumbnails
Click image for larger version

Name:	20170303_001335_1488518196954.jpg
Views:	31
Size:	42.5 KB
ID:	151394  
ambiguity is offline  
post #119 of 120 (permalink) Old 03-04-2017, 01:41 AM
prg
Member
 
Join Date: Jul 2016
Location: Carlsbad, CA
Posts: 13
Shadow

I think I notice the same shadow or line on mine. Not terribly noticeable but there if you look. After a few weeks I am really pleased with my HID's.

Having the HID's fire up every time I unlock the car has been bugging me, probably not the best for the bulbs. I am probably not the first to figure this out, but if you go into settings on the UConnect/Lights, Approach Delay, and set it to "0", the lights don't come on when you unlock. Also disable flash when locking. phil
Duke2015 likes this.

prg
2016 TH
prg is offline  
post #120 of 120 (permalink) Old 03-04-2017, 09:43 PM
Member
 
ambiguity's Avatar
 
Join Date: Apr 2016
Posts: 49
Quote:
Originally Posted by prg View Post
I think I notice the same shadow or line on mine. Not terribly noticeable but there if you look. After a few weeks I am really pleased with my HID's.

Having the HID's fire up every time I unlock the car has been bugging me, probably not the best for the bulbs. I am probably not the first to figure this out, but if you go into settings on the UConnect/Lights, Approach Delay, and set it to "0", the lights don't come on when you unlock. Also disable flash when locking. phil
Thanks! Turning the fogs on drowns it out some, but I pay attention to it too much on my ride home from work

I am still trying to debug the light out issue I am having with the hid kit - XD wants me to recreate it with the car off so I will leave that feature on for a moment, but thanks for the tip!

2016 Jeep Altitude
Black on black
Cold Weather Package
Comfort & Convenience Package
Safety Package
Panoramic Sun Roof
Navigation
Tow Package
ambiguity is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the 2014+ Jeep Cherokee Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



  Similar Threads
Thread Thread Starter Forum Replies Last Post
2016 XenonDepot HID kit install justforfun Electronics, Audio, and Lighting 189 03-06-2017 03:45 PM
XenonDepot HID kit installation guide ptrudel Electronics, Audio, and Lighting 51 11-06-2016 11:51 AM
HID's turns Night into Day A (nother XenonDepot Kit) White Eagle Hawk Electronics, Audio, and Lighting 11 01-07-2016 10:25 AM
XenonDepot xtreme hid kit starting to fail after 6 months? XtremeModder Electronics, Audio, and Lighting 5 11-22-2015 08:26 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On