XenonDepot HID kit step by step installation guide - Page 3 - 2014+ Jeep Cherokee Forums
User Tag List

 32Likes
Reply
 
LinkBack Thread Tools
post #21 of 120 (permalink) Old 08-25-2016, 01:19 AM
Member
 
cherokeebill's Avatar
 
Join Date: Dec 2015
Location: Castlegar, B.C.
Posts: 59
Mine had the foam sleeves too. I did not see a plastic cap. No where in the installation guide did they mention plastic caps. I don;t think there are any on the more recent kits. Anyone else?

2015 Cherokee North; 3.2V6, Tow group, cold weather group, 8.4 Uconnect w back up camera, Tuhle racks. Nokian all weather tires. XenonDepot 4300k
cherokeebill is offline  
Sponsored Links
Advertisement
 
post #22 of 120 (permalink) Old 08-25-2016, 11:15 AM
Forum Elder
 
Toecutter's Avatar
 
Join Date: Dec 2013
Location: Bend, Oregon
Posts: 1,653
Maybe it's a Philips bulb (plastic cap) versus non-Philips bulb (foam sleeve) packaging thing?

2014 Trail Hawk
V6 | Anvil | Black leather | Tow | Comfort | Cold | Tech | Nav | Subwoofer | Soul patch | 20% tint | 245/70R17 Duratrac
Toecutter is offline  
post #23 of 120 (permalink) Old 08-26-2016, 04:17 PM
Member
 
Join Date: Aug 2016
Posts: 22
So I received my HID Kit yesterday and installed it last night. Couple of thoughts worth sharing:

- You need to re-align the headlights. My halogens never were an issue for oncoming traffic but I got flashed with the HIDs 6-8 times on my test drive.

This video was useful for me to properly adjust the lights: https://youtu.be/qDudMM4J-ZE

You need to turn the little funnels behind the lamp assembly by using a Hex driver/Allen key. It took me about 10min to measure proper distances and make the adjustment.

- The passenger side sporadically won't come on when the headlights turn on. Didn't get any codes or "Bulb out" messages but sometimes the light won't work. I checked all connections and they are as tight as can be. A quick restart of the car usually fixes this issue which only happened twice on a total of 7 drives.

- The passenger side ballast also has a noticeable buzz (from outside the cabin) coming out of it while the driver side ballast is silent.

- I also share other members' suspicion that the shadow on the driver's side is coming from the filament. It is also present on the passenger side but gets filled in by the driver side lamp.

Overall, I'm extremely happy with the install which took less than an hour (I didn't remove the wheels or the liner, did everything through the access panels). Highly recommended to anyone who wishes to have the luxury of sight with their KL at night.


Sent from my iPhone using Tapatalk
paultn likes this.
allleee is offline  
 
post #24 of 120 (permalink) Old 08-26-2016, 04:58 PM
Member
 
Join Date: Apr 2016
Posts: 44
Quote:
Originally Posted by allleee View Post
So I received my HID Kit yesterday and installed it last night. Couple of thoughts worth sharing:

- You need to re-align the headlights. My halogens never were an issue for oncoming traffic but I got flashed with the HIDs 6-8 times on my test drive.

This video was useful for me to properly adjust the lights: https://youtu.be/qDudMM4J-ZE

You need to turn the little funnels behind the lamp assembly by using a Hex driver/Allen key. It took me about 10min to measure proper distances and make the adjustment.

- The passenger side sporadically won't come on when the headlights turn on. Didn't get any codes or "Bulb out" messages but sometimes the light won't work. I checked all connections and they are as tight as can be. A quick restart of the car usually fixes this issue which only happened twice on a total of 7 drives.

- The passenger side ballast also has a noticeable buzz (from outside the cabin) coming out of it while the driver side ballast is silent.

- I also share other members' suspicion that the shadow on the driver's side is coming from the filament. It is also present on the passenger side but gets filled in by the driver side lamp.

Overall, I'm extremely happy with the install which took less than an hour (I didn't remove the wheels or the liner, did everything through the access panels). Highly recommended to anyone who wishes to have the luxury of sight with their KL at night.


Sent from my iPhone using Tapatalk
Your passenger light not coming on always, go in there when it's off and wiggle each of the connections individually, when the lights come on that will tell you which one is the issue. Then check that pins are seated all the way and correct orientation. Mine was a pin in the pwm module to ballast connection.

Sent from my VS985 4G using Tapatalk
allleee likes this.

Last edited by brent; 08-26-2016 at 06:37 PM.
brent is offline  
post #25 of 120 (permalink) Old 08-26-2016, 05:44 PM
Member
 
Join Date: Jan 2016
Location: Houston
Posts: 13
@dspears0809 - I've been meaning to send you pictures, but my vehicle is getting a new transmission. I'll post some when I get it back. On the driver's side, I stuck the larger box to the sidewall sheet metal and zip-tied the other modules to the existing wiring conduit along the side. On the passenger side, I stuck all 3 boxes to the sheet metal. The larger was placed far back, closer to the windshield and the smaller two next to the air filter box. Regarding the o-ring, yours probably didn't fall off of the cap, but mine did. It would be hard to miss if it was sitting on the floor. Yours is probably on. Disconnecting the battery always generates these errors for a while. I left mine connected when I installed the lights - maybe not the best idea, but I hate getting all those errors. I suspect if you reconnect the battery and leave it for a while before turning anything on in the vehicle, it may not happen - give modules time to boot up. Don't know if that's true, but a theory.

@Toecutter - I think you are correct about the plastic vs. foam. Mine had the plastic covers and are Phillips.

@ptrudel - Yes, the grommet must be bigger. Maybe XD can comment if they made a change and the instructions you made could be updated.

15 TH Anvil, Tech, C/C, Safety, UConnect 8.4AN. Mods: RAX, Sharkfin Antenna, Android Box, XD HID 4300K, Aussie Lift (HazardSky), BFG KO2 255/70R17
Sully is offline  
post #26 of 120 (permalink) Old 09-09-2016, 03:17 PM
Member
 
Sylvestermax's Avatar
 
Join Date: Sep 2016
Location: Tampa, FL
Posts: 50
High/Low beam question

Hello, I'm new here.
I plan on buying a new Cherokee TH within the next month or so and I'd like replace the stock halogens with HIDs or high quality LEDs. I have put HID kits on other cars I have owned with success. One car had a separate light bulbs for the high beam and low beams and the other had two filament High/Low beam combined halogen bulbs. The HID bulb for that application actually moved in and out when the "high beams" were selected in order to move the light in relation to the reflector to move the light pattern higher.
How do the High and Low beams work on the Cherokee? Does it use a shutter like the Bi-Xenons projector lights on my BMW which removes the beam cutoff when high beams are selected, or does it have a dual filament Halogen bulb?
With the advancement in LED technology, can anyone recommend an LED bulb with the same light output as the HIDs?
Sorry for the long post, Thanks for any help.
Sylvestermax is offline  
post #27 of 120 (permalink) Old 09-09-2016, 08:18 PM
Forum Elder
 
goobnav's Avatar
 
Join Date: Dec 2015
Location: Durham, NC
Posts: 1,665
Garage
The lights are a shutter type.

2016 TH, V6, C&C, Tow group, 8.4AN, leather, Cold Weather, Command Sunroof, Black wheels, & Black. Maxcare Unlimited Miles and Years $100 Deductible.
goobnav is offline  
post #28 of 120 (permalink) Old 09-09-2016, 09:12 PM
Enthusiast Member
 
Arct1c4x4's Avatar
 
Join Date: Aug 2016
Location: Bay Area Northern CA
Posts: 133
hi which HID kit is this specifically? i have a 2016 TH. great PDF, super helpful. thank you!
Arct1c4x4 is offline  
post #29 of 120 (permalink) Old 09-09-2016, 09:46 PM
Member
 
Join Date: Sep 2016
Posts: 57
Thanks for the write up. I ordered a vehicle specific Extreme HID kit from XenonDepot, it arrived quickly as promised and appeared high quality. That said...I couldn't get it to work on my '16 Trailhawk. I spoke to Rob over there a few times today, trying everything he could think of. Did a 100% part swap including bulbs, reversed polarity at the black/white wired plug, everything...just could not get it to fire. Put my stock, crap halogen back in, and it works fine. Fine meaning it comes on but still sucks as these lights do. Truly a bummer on the kit for me, I really wanted it to work. I either got really unlucky, the bulbs broke during shipping, or there's something different about my TH based off build date or something. For what it's worth, it uses 9005 bulbs, build date is 12/2015. Thank you for the write up, it did help me be sure that the error wasn't (likely) me.
BombDoc is offline  
post #30 of 120 (permalink) Old 09-22-2016, 11:31 PM
Premium Member
 
Taindew's Avatar
 
Join Date: Apr 2015
Location: Colorado
Posts: 63
Garage
Has anyone had your HID headlight begin to discolor? I installed mine a little more than a year ago into my '15 TH and my driver side is turning a slight tan/orange from it's original 5000K bright white. I have gone off roading a ton, and some river crossing may have exposed the highlight to water.... never really checked.

Will post a pic later to show case what I have begun to notice.

2015 Granite Trailhawk | 3.2-L V6 | Active Drive II | Trailer Tow Group | Cold Weather Group | Uconnect 8.4AN | Born January 2015 |
Taindew is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the 2014+ Jeep Cherokee Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



  Similar Threads
Thread Thread Starter Forum Replies Last Post
2016 XenonDepot HID kit install justforfun Electronics, Audio, and Lighting 189 03-06-2017 03:45 PM
XenonDepot HID kit installation guide ptrudel Electronics, Audio, and Lighting 51 11-06-2016 11:51 AM
HID's turns Night into Day A (nother XenonDepot Kit) White Eagle Hawk Electronics, Audio, and Lighting 11 01-07-2016 10:25 AM
XenonDepot xtreme hid kit starting to fail after 6 months? XtremeModder Electronics, Audio, and Lighting 5 11-22-2015 08:26 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On