SiriusXM Service Loading Issue - 2014+ Jeep Cherokee Forums
User Tag List

 1Likes
  • 1 Post By purelithium
 
LinkBack Thread Tools
post #1 of 6 (permalink) Old 05-18-2017, 09:42 AM Thread Starter
Member
 
ScottCT1's Avatar
 
Join Date: Jan 2014
Location: Newington, CT USA!
Posts: 53
Garage
SiriusXM Service Loading Issue

About two weeks ago while listening to SiriusXM the audio dropped off, and on the screen appears a message that SiriusXM Was Loading.

Since that has happened now while driving or staying stationary, this is happening about every 5 to 10 minutes. Sometimes everything starts working again in 5 - 10 seconds and other times it stays stuck on this screen and the only way to get Satellite Radio back is to turn off and restart the car.

Also my travel link no longer works, when I click on Fuel Prices it just says Loading... and sits there and never loads. This was working before this problem started. The Travel Link service came with the car and is a 3 year subscription, so it should be working.

Is there anything I can do to try resetting my system? Or is it something I should take to the dealer?

This is a 2016 Cherokee Limited with Navigation.
ScottCT1 is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old 05-18-2017, 09:52 AM
Member
 
purelithium's Avatar
 
Join Date: May 2017
Location: Ottawa, Ontario, Canada
Posts: 30
Garage
Sounds like a loose connector somewhere to me. Take it to the dealer.


purelithium
ScottCT1 likes this.

purelithium

2016 North 3.2

Pro Patria
purelithium is offline  
post #3 of 6 (permalink) Old 05-18-2017, 10:56 AM
Forum Elder
 
ptram's Avatar
 
Join Date: Nov 2013
Posts: 2,596
Quote:
Originally Posted by purelithium View Post
Sounds like a loose connector somewhere to me. Take it to the dealer.


purelithium

I agree that you may need to take it to a dealer---but have you called SiriusXM Service to see if they have any suggestions?s

2017 Trailhawk L Plus 4 bX4,Rhino exterior,Power 8 way drivers seat, Willys in windshidel,Cold Weather Group, Comfort/Convenience Group,Trailer Tow Group, 3.2 -Liter V6, Black Hood Decal , Uconnect 8.4 , Safety Tech Group, Leather Interior Group, Ventilated/Memory seat Group,Navigation. No hole in roof.

2017 KL Latitude-4 by 4 Cherry Red, V-6, Safety/Convenience group, Cold Weather Group,which includes heated front seats--love those heated seats,
ptram is offline  
 
post #4 of 6 (permalink) Old 05-18-2017, 01:37 PM
Premium Member
 
Join Date: Apr 2016
Posts: 382
Quote:
Originally Posted by ScottCT1 View Post
About two weeks ago while listening to SiriusXM the audio dropped off, and on the screen appears a message that SiriusXM Was Loading.

Since that has happened now while driving or staying stationary, this is happening about every 5 to 10 minutes. Sometimes everything starts working again in 5 - 10 seconds and other times it stays stuck on this screen and the only way to get Satellite Radio back is to turn off and restart the car.

Also my travel link no longer works, when I click on Fuel Prices it just says Loading... and sits there and never loads. This was working before this problem started. The Travel Link service came with the car and is a 3 year subscription, so it should be working.

Is there anything I can do to try resetting my system? Or is it something I should take to the dealer?

This is a 2016 Cherokee Limited with Navigation.
Hi ScottCT1,

We would recommend visiting your local dealership for further diagnosis. You could also try contacting SiriusXM's Customer Service team at 1 (866) 635-5027 for troubleshooting assistance. Feel free to PM our page with any additional questions or concerns!

Andrea
Jeep Social Care Specialist
JeepCares is online now  
post #5 of 6 (permalink) Old 05-18-2017, 07:33 PM
Hardcore Member
 
dhh3's Avatar
 
Join Date: Aug 2016
Location: Fort Wayne, Indiana
Posts: 1,334
Garage
All Sirius can do is refresh your signal. Sounds to me to be an antenna issue; intermittent disconnect.

2016 Cherokee Trailhawk: Mango Tango Pearl Coat over Black.
OPTIONS: Every Available Factory Option/Package Except Remote CD Player.
MODS: Whispbars; Mopar Cargo Cover; Mopar Cargo Mat; Mopar/KICKER 9 Speaker Upgrade; KICKER Sub and Amp; Ziebart Undercoating; aFe CAI.
FUTURE MODS: Remote CD Player; Mopar Rock Rails; Rear Fog Lights.
dhh3 is offline  
post #6 of 6 (permalink) Old 05-18-2017, 09:18 PM
Member
 
Mxttric's Avatar
 
Join Date: Mar 2017
Location: Round Lake, IL
Posts: 23
Garage
Could be the Antenna but also but most likely loose connection either in the back of the system or by the fuses.

The best preparation for tomorrow is doing your best today.
Mxttric is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the 2014+ Jeep Cherokee Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



  Similar Threads
Thread Thread Starter Forum Replies Last Post
Diesel 40K service & Uconnect Navigation issue Condo Australia 4 02-25-2017 05:18 PM
hands free module loading - please wait: back at the dealer again Zoramac Electronics, Audio, and Lighting 6 01-20-2017 11:32 AM
Hands-Free System Loading.. Please wait.. Zoramac Electronics, Audio, and Lighting 3 08-20-2015 11:16 AM
SiriusXM Favorites Station Issue Ben_e Electronics, Audio, and Lighting 2 05-12-2015 06:36 PM
Service at 4,300 Miles and Vibration Issue TonyC Engine and Technical Discussion 0 06-20-2014 04:18 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On